56 lines
1.7 KiB
Diff
56 lines
1.7 KiB
Diff
From 12351a91da97b414eec8cdb09f1d9f41e535a401 Mon Sep 17 00:00:00 2001
|
|
From: Li Qiang <liqiang6-s@360.cn>
|
|
Date: Wed, 14 Dec 2016 18:30:21 -0800
|
|
Subject: [PATCH] audio: ac97: add exit function
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=utf8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
http://git.qemu.org/?p=qemu.git;a=patch;h=12351a91da97b414eec8cdb09f1d9f41e535a401
|
|
this patch is from qemu-git
|
|
|
|
Currently the ac97 device emulation doesn't have a exit function,
|
|
hot unplug this device will leak some memory. Add a exit function to
|
|
avoid this.
|
|
|
|
Signed-off-by: Li Qiang <liqiang6-s@360.cn>
|
|
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
|
Message-id: 58520052.4825ed0a.27a71.6cae@mx.google.com
|
|
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
|
---
|
|
hw/audio/ac97.c | 11 +++++++++++
|
|
1 files changed, 11 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/hw/audio/ac97.c b/hw/audio/ac97.c
|
|
index cbd959e..c306575 100644
|
|
--- a/hw/audio/ac97.c
|
|
+++ b/hw/audio/ac97.c
|
|
@@ -1387,6 +1387,16 @@ static void ac97_realize(PCIDevice *dev, Error **errp)
|
|
ac97_on_reset (&s->dev.qdev);
|
|
}
|
|
|
|
+static void ac97_exit(PCIDevice *dev)
|
|
+{
|
|
+ AC97LinkState *s = DO_UPCAST(AC97LinkState, dev, dev);
|
|
+
|
|
+ AUD_close_in(&s->card, s->voice_pi);
|
|
+ AUD_close_out(&s->card, s->voice_po);
|
|
+ AUD_close_in(&s->card, s->voice_mc);
|
|
+ AUD_remove_card(&s->card);
|
|
+}
|
|
+
|
|
static int ac97_init (PCIBus *bus)
|
|
{
|
|
pci_create_simple (bus, -1, "AC97");
|
|
@@ -1404,6 +1414,7 @@ static void ac97_class_init (ObjectClass *klass, void *data)
|
|
PCIDeviceClass *k = PCI_DEVICE_CLASS (klass);
|
|
|
|
k->realize = ac97_realize;
|
|
+ k->exit = ac97_exit;
|
|
k->vendor_id = PCI_VENDOR_ID_INTEL;
|
|
k->device_id = PCI_DEVICE_ID_INTEL_82801AA_5;
|
|
k->revision = 0x01;
|
|
--
|
|
1.7.0.4
|
|
|