45 lines
1.6 KiB
Diff
45 lines
1.6 KiB
Diff
From 33243031dad02d161225ba99d782616da133f689 Mon Sep 17 00:00:00 2001
|
|
From: Li Qiang <liq3ea@gmail.com>
|
|
Date: Thu, 29 Dec 2016 03:11:26 -0500
|
|
Subject: [PATCH] virtio-gpu-3d: fix memory leak in resource attach backing
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=utf8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
If the virgl_renderer_resource_attach_iov function fails the
|
|
'res_iovs' will be leaked. Add check of the return value to
|
|
free the 'res_iovs' when failing.
|
|
|
|
http://git.qemu.org/?p=qemu.git;a=patch;h=33243031dad02d161225ba99d782616da133f689
|
|
this patch is from qemu-git.
|
|
|
|
Signed-off-by: Li Qiang <liq3ea@gmail.com>
|
|
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
|
Message-id: 1482999086-59795-1-git-send-email-liq3ea@gmail.com
|
|
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
|
---
|
|
hw/display/virtio-gpu-3d.c | 7 +++++--
|
|
1 files changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/hw/display/virtio-gpu-3d.c b/hw/display/virtio-gpu-3d.c
|
|
index e29f099..b13ced3 100644
|
|
--- a/hw/display/virtio-gpu-3d.c
|
|
+++ b/hw/display/virtio-gpu-3d.c
|
|
@@ -291,8 +291,11 @@ static void virgl_resource_attach_backing(VirtIOGPU *g,
|
|
return;
|
|
}
|
|
|
|
- virgl_renderer_resource_attach_iov(att_rb.resource_id,
|
|
- res_iovs, att_rb.nr_entries);
|
|
+ ret = virgl_renderer_resource_attach_iov(att_rb.resource_id,
|
|
+ res_iovs, att_rb.nr_entries);
|
|
+
|
|
+ if (ret != 0)
|
|
+ virtio_gpu_cleanup_mapping_iov(res_iovs, att_rb.nr_entries);
|
|
}
|
|
|
|
static void virgl_resource_detach_backing(VirtIOGPU *g,
|
|
--
|
|
1.7.0.4
|
|
|