48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
Fix CVE-2017-2630:
|
|
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2630
|
|
https://lists.gnu.org/archive/html/qemu-devel/2017-02/msg01246.html
|
|
|
|
Patch copied from upstream source repository:
|
|
|
|
http://git.qemu-project.org/?p=qemu.git;a=commit;h=2563c9c6b8670400c48e562034b321a7cf3d9a85
|
|
|
|
From 2563c9c6b8670400c48e562034b321a7cf3d9a85 Mon Sep 17 00:00:00 2001
|
|
From: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
|
|
Date: Tue, 7 Mar 2017 09:16:27 -0600
|
|
Subject: [PATCH] nbd/client: fix drop_sync [CVE-2017-2630]
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Comparison symbol is misused. It may lead to memory corruption.
|
|
Introduced in commit 7d3123e.
|
|
|
|
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
|
|
Message-Id: <20170203154757.36140-6-vsementsov@virtuozzo.com>
|
|
[eblake: add CVE details, update conditional]
|
|
Signed-off-by: Eric Blake <eblake@redhat.com>
|
|
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
|
Message-Id: <20170307151627.27212-1-eblake@redhat.com>
|
|
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
|
---
|
|
nbd/client.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/nbd/client.c b/nbd/client.c
|
|
index 5c9dee37fa..3dc2564cd0 100644
|
|
--- a/nbd/client.c
|
|
+++ b/nbd/client.c
|
|
@@ -94,7 +94,7 @@ static ssize_t drop_sync(QIOChannel *ioc, size_t size)
|
|
char small[1024];
|
|
char *buffer;
|
|
|
|
- buffer = sizeof(small) < size ? small : g_malloc(MIN(65536, size));
|
|
+ buffer = sizeof(small) >= size ? small : g_malloc(MIN(65536, size));
|
|
while (size > 0) {
|
|
ssize_t count = read_sync(ioc, buffer, MIN(65536, size));
|
|
|
|
--
|
|
2.12.0
|
|
|