32 lines
1.0 KiB
Diff
32 lines
1.0 KiB
Diff
From ea861fe86743c8402bbad77d8d1dd9de8dce447e Mon Sep 17 00:00:00 2001
|
|
From: Mikkel Krautz <mikkel@krautz.dk>
|
|
Date: Fri, 29 Dec 2017 14:47:25 +0100
|
|
Subject: [PATCH] AudioOutput: do not use non-existant template version of
|
|
std::abs.
|
|
|
|
This change fixes AudioOutput to use the float overload of std::abs:
|
|
|
|
float std::abs(float);
|
|
|
|
instead of a non-existant template version (for newer Boost 1.66).
|
|
|
|
Fixes mumble-voip/mumble#3281
|
|
|
|
---
|
|
src/mumble/AudioOutput.cpp | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/mumble/AudioOutput.cpp b/src/mumble/AudioOutput.cpp
|
|
index cbe0c0e2b..7a0a5e2ab 100644
|
|
--- a/src/mumble/AudioOutput.cpp
|
|
+++ b/src/mumble/AudioOutput.cpp
|
|
@@ -437,7 +437,7 @@ bool AudioOutput::mix(void *outbuff, unsigned int nsamp) {
|
|
top[2] = 0.0f;
|
|
}
|
|
|
|
- if (std::abs<float>(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
|
|
+ if (std::abs(front[0] * top[0] + front[1] * top[1] + front[2] * top[2]) > 0.01f) {
|
|
// Not perpendicular. Assume Y up and rotate 90 degrees.
|
|
|
|
float azimuth = 0.0f;
|