54 lines
2.2 KiB
Diff
54 lines
2.2 KiB
Diff
Fix CVE-2018-14526:
|
|
|
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14526
|
|
https://w1.fi/security/2018-1/unauthenticated-eapol-key-decryption.txt
|
|
|
|
Patch downloaded from upstream:
|
|
|
|
https://w1.fi/security/2018-1/rebased-v2.6-0001-WPA-Ignore-unauthenticated-encrypted-EAPOL-Key-data.patch
|
|
|
|
From 3e34cfdff6b192fe337c6fb3f487f73e96582961 Mon Sep 17 00:00:00 2001
|
|
From: Mathy Vanhoef <Mathy.Vanhoef@cs.kuleuven.be>
|
|
Date: Sun, 15 Jul 2018 01:25:53 +0200
|
|
Subject: [PATCH] WPA: Ignore unauthenticated encrypted EAPOL-Key data
|
|
|
|
Ignore unauthenticated encrypted EAPOL-Key data in supplicant
|
|
processing. When using WPA2, these are frames that have the Encrypted
|
|
flag set, but not the MIC flag.
|
|
|
|
When using WPA2, EAPOL-Key frames that had the Encrypted flag set but
|
|
not the MIC flag, had their data field decrypted without first verifying
|
|
the MIC. In case the data field was encrypted using RC4 (i.e., when
|
|
negotiating TKIP as the pairwise cipher), this meant that
|
|
unauthenticated but decrypted data would then be processed. An adversary
|
|
could abuse this as a decryption oracle to recover sensitive information
|
|
in the data field of EAPOL-Key messages (e.g., the group key).
|
|
(CVE-2018-14526)
|
|
|
|
Signed-off-by: Mathy Vanhoef <Mathy.Vanhoef@cs.kuleuven.be>
|
|
---
|
|
src/rsn_supp/wpa.c | 11 +++++++++++
|
|
1 file changed, 11 insertions(+)
|
|
|
|
diff -upr wpa_supplicant-2.6.orig/src/rsn_supp/wpa.c wpa_supplicant-2.6/src/rsn_supp/wpa.c
|
|
--- wpa_supplicant-2.6.orig/src/rsn_supp/wpa.c 2016-10-02 21:51:11.000000000 +0300
|
|
+++ wpa_supplicant-2.6/src/rsn_supp/wpa.c 2018-08-08 16:55:11.506831029 +0300
|
|
@@ -2016,6 +2016,17 @@ int wpa_sm_rx_eapol(struct wpa_sm *sm, c
|
|
|
|
if ((sm->proto == WPA_PROTO_RSN || sm->proto == WPA_PROTO_OSEN) &&
|
|
(key_info & WPA_KEY_INFO_ENCR_KEY_DATA)) {
|
|
+ /*
|
|
+ * Only decrypt the Key Data field if the frame's authenticity
|
|
+ * was verified. When using AES-SIV (FILS), the MIC flag is not
|
|
+ * set, so this check should only be performed if mic_len != 0
|
|
+ * which is the case in this code branch.
|
|
+ */
|
|
+ if (!(key_info & WPA_KEY_INFO_MIC)) {
|
|
+ wpa_msg(sm->ctx->msg_ctx, MSG_WARNING,
|
|
+ "WPA: Ignore EAPOL-Key with encrypted but unauthenticated data");
|
|
+ goto out;
|
|
+ }
|
|
if (wpa_supplicant_decrypt_key_data(sm, key, ver, key_data,
|
|
&key_data_len))
|
|
goto out;
|