gnu: xf86-video-ast: Add patch needed for upcoming xorg-server update.
* gnu/packages/patches/xf86-video-ast-remove-mibstore.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-video-ast): Add patch. Use modular xorg source URI.
This commit is contained in:
parent
232af79efb
commit
3ee26f989c
|
@ -459,6 +459,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/w3m-fix-compile.patch \
|
||||
gnu/packages/patches/wmctrl-64-fix.patch \
|
||||
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
||||
gnu/packages/patches/xf86-video-geode-glibc-2.20.patch \
|
||||
gnu/packages/patches/xf86-video-openchrome-includes.patch \
|
||||
gnu/packages/patches/xfce4-panel-plugins.patch \
|
||||
|
|
|
@ -0,0 +1,90 @@
|
|||
Removes references to mibstore.h and miInitializeBackingStore, which
|
||||
have been removed from xorg-server. Zack Rusin <zackr@vmware.com>
|
||||
wrote: "It was a noop for at least 5 years and it has been removed."
|
||||
See: http://patches.openembedded.org/patch/46133/
|
||||
|
||||
diff -ru xf86-video-ast-0.93.10.orig/src/ast_2dtool.c xf86-video-ast-0.93.10/src/ast_2dtool.c
|
||||
--- xf86-video-ast-0.93.10.orig/src/ast_2dtool.c 2012-03-23 21:40:56.000000000 -0400
|
||||
+++ xf86-video-ast-0.93.10/src/ast_2dtool.c 2014-12-19 02:42:32.422383728 -0500
|
||||
@@ -27,7 +27,6 @@
|
||||
#include "xf86_OSproc.h"
|
||||
#include "xf86cmap.h"
|
||||
#include "compiler.h"
|
||||
-#include "mibstore.h"
|
||||
#include "vgaHW.h"
|
||||
#include "mipointer.h"
|
||||
#include "micmap.h"
|
||||
diff -ru xf86-video-ast-0.93.10.orig/src/ast_accel.c xf86-video-ast-0.93.10/src/ast_accel.c
|
||||
--- xf86-video-ast-0.93.10.orig/src/ast_accel.c 2012-03-23 21:40:56.000000000 -0400
|
||||
+++ xf86-video-ast-0.93.10/src/ast_accel.c 2014-12-19 02:41:55.534200809 -0500
|
||||
@@ -27,7 +27,6 @@
|
||||
#include "xf86_OSproc.h"
|
||||
#include "xf86cmap.h"
|
||||
#include "compiler.h"
|
||||
-#include "mibstore.h"
|
||||
#include "vgaHW.h"
|
||||
#include "mipointer.h"
|
||||
#include "micmap.h"
|
||||
diff -ru xf86-video-ast-0.93.10.orig/src/ast_cursor.c xf86-video-ast-0.93.10/src/ast_cursor.c
|
||||
--- xf86-video-ast-0.93.10.orig/src/ast_cursor.c 2012-03-23 21:40:56.000000000 -0400
|
||||
+++ xf86-video-ast-0.93.10/src/ast_cursor.c 2014-12-19 02:42:37.258407708 -0500
|
||||
@@ -27,7 +27,6 @@
|
||||
#include "xf86_OSproc.h"
|
||||
#include "xf86cmap.h"
|
||||
#include "compiler.h"
|
||||
-#include "mibstore.h"
|
||||
#include "vgaHW.h"
|
||||
#include "mipointer.h"
|
||||
#include "micmap.h"
|
||||
diff -ru xf86-video-ast-0.93.10.orig/src/ast_driver.c xf86-video-ast-0.93.10/src/ast_driver.c
|
||||
--- xf86-video-ast-0.93.10.orig/src/ast_driver.c 2012-03-23 21:40:56.000000000 -0400
|
||||
+++ xf86-video-ast-0.93.10/src/ast_driver.c 2014-12-19 02:42:50.710474414 -0500
|
||||
@@ -31,7 +31,6 @@
|
||||
#endif
|
||||
#include "xf86cmap.h"
|
||||
#include "compiler.h"
|
||||
-#include "mibstore.h"
|
||||
#include "vgaHW.h"
|
||||
#include "mipointer.h"
|
||||
#include "micmap.h"
|
||||
@@ -865,7 +864,6 @@
|
||||
}
|
||||
#endif /* end of Accel_2D */
|
||||
|
||||
- miInitializeBackingStore(pScreen);
|
||||
xf86SetBackingStore(pScreen);
|
||||
xf86SetSilkenMouse(pScreen);
|
||||
|
||||
diff -ru xf86-video-ast-0.93.10.orig/src/ast_mode.c xf86-video-ast-0.93.10/src/ast_mode.c
|
||||
--- xf86-video-ast-0.93.10.orig/src/ast_mode.c 2012-03-23 21:40:56.000000000 -0400
|
||||
+++ xf86-video-ast-0.93.10/src/ast_mode.c 2014-12-19 02:42:24.894346398 -0500
|
||||
@@ -27,7 +27,6 @@
|
||||
#include "xf86_OSproc.h"
|
||||
#include "xf86cmap.h"
|
||||
#include "compiler.h"
|
||||
-#include "mibstore.h"
|
||||
#include "vgaHW.h"
|
||||
#include "mipointer.h"
|
||||
#include "micmap.h"
|
||||
diff -ru xf86-video-ast-0.93.10.orig/src/ast_tool.c xf86-video-ast-0.93.10/src/ast_tool.c
|
||||
--- xf86-video-ast-0.93.10.orig/src/ast_tool.c 2012-03-23 21:40:56.000000000 -0400
|
||||
+++ xf86-video-ast-0.93.10/src/ast_tool.c 2014-12-19 02:42:03.930242443 -0500
|
||||
@@ -27,7 +27,6 @@
|
||||
#include "xf86_OSproc.h"
|
||||
#include "xf86cmap.h"
|
||||
#include "compiler.h"
|
||||
-#include "mibstore.h"
|
||||
#include "vgaHW.h"
|
||||
#include "mipointer.h"
|
||||
#include "micmap.h"
|
||||
diff -ru xf86-video-ast-0.93.10.orig/src/ast_vgatool.c xf86-video-ast-0.93.10/src/ast_vgatool.c
|
||||
--- xf86-video-ast-0.93.10.orig/src/ast_vgatool.c 2012-03-23 21:40:56.000000000 -0400
|
||||
+++ xf86-video-ast-0.93.10/src/ast_vgatool.c 2014-12-19 02:42:18.406314226 -0500
|
||||
@@ -27,7 +27,6 @@
|
||||
#include "xf86_OSproc.h"
|
||||
#include "xf86cmap.h"
|
||||
#include "compiler.h"
|
||||
-#include "mibstore.h"
|
||||
#include "vgaHW.h"
|
||||
#include "mipointer.h"
|
||||
#include "micmap.h"
|
|
@ -2389,12 +2389,13 @@ devices, thus making direct access unnecessary.")
|
|||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://xorg/X11R7.7/src/everything/xf86-video-ast-"
|
||||
"mirror://xorg/individual/driver/xf86-video-ast-"
|
||||
version
|
||||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1q64z8qqa0ix3cymqiwk1s3sphd1fvvz30lvyxhgkgciygz6dm69"))))
|
||||
"1q64z8qqa0ix3cymqiwk1s3sphd1fvvz30lvyxhgkgciygz6dm69"))
|
||||
(patches (list (search-patch "xf86-video-ast-remove-mibstore.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("xorg-server" ,xorg-server)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||
|
|
Loading…
Reference in New Issue