gnu: gtk+: Add patch to support GUIX_GTK3_PATH.

* gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/gtk.scm (gtk+) [source]: Add patch.
[native-search-paths]: Add search path for GUIX_GTK3_PATH.
master
Ricardo Wurmus 2015-12-03 08:32:06 +01:00 committed by Mark H Weaver
parent 2a6afac905
commit 4828ff91ff
3 changed files with 46 additions and 2 deletions

View File

@ -507,6 +507,7 @@ dist_patch_DATA = \
gnu/packages/patches/guile-relocatable.patch \
gnu/packages/patches/guile-rsvg-pkgconfig.patch \
gnu/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
gnu/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch \
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
gnu/packages/patches/hop-bigloo-4.0b.patch \
gnu/packages/patches/hop-linker-flags.patch \

View File

@ -583,7 +583,8 @@ application suites.")
name "-" version ".tar.xz"))
(sha256
(base32
"0lp1hn0qydxx03bianzzr0a4maqzsvylrkzr7c3p0050qihwbgjx"))))
"0lp1hn0qydxx03bianzzr0a4maqzsvylrkzr7c3p0050qihwbgjx"))
(patches (list (search-patch "gtk3-respect-GUIX_GTK3_PATH.patch")))))
(propagated-inputs
`(("at-spi2-atk" ,at-spi2-atk)
("atk" ,atk)
@ -642,7 +643,11 @@ application suites.")
(loaders.cache (find-files librsvg "^loaders\\.cache$")))
(wrap-program prog
`("GDK_PIXBUF_MODULE_FILE" = ,loaders.cache))))
%standard-phases))))))
%standard-phases))))
(native-search-paths
(list (search-path-specification
(variable "GUIX_GTK3_PATH")
(files '("lib/gtk-3.0")))))))
;;;
;;; Guile bindings.

View File

@ -0,0 +1,38 @@
This patch makes GTK+ look for additional modules in a list of directories
specified by the environment variable "GUIX_GTK3_PATH". This can be used
instead of "GTK_PATH" to make GTK+ find modules that are incompatible with
other major versions of GTK+.
--- a/gtk/gtkmodules.c 2015-09-20 20:09:05.060590217 +0200
+++ b/gtk/gtkmodules.c 2015-09-20 20:10:33.423124833 +0200
@@ -52,6 +52,7 @@
get_module_path (void)
{
const gchar *module_path_env;
+ const gchar *module_guix_gtk3_path_env;
const gchar *exe_prefix;
gchar *module_path;
gchar *default_dir;
@@ -61,6 +62,7 @@
return result;
module_path_env = g_getenv ("GTK_PATH");
+ module_guix_gtk3_path_env = g_getenv ("GUIX_GTK3_PATH");
exe_prefix = g_getenv ("GTK_EXE_PREFIX");
if (exe_prefix)
@@ -68,7 +70,13 @@
else
default_dir = g_build_filename (_gtk_get_libdir (), "gtk-3.0", NULL);
- if (module_path_env)
+ if (module_guix_gtk3_path_env && module_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk3_path_env, module_path_env, default_dir, NULL);
+ else if (module_guix_gtk3_path_env)
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
+ module_guix_gtk3_path_env, default_dir, NULL);
+ else if (module_path_env)
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
module_path_env, default_dir, NULL);
else