Revert "gnu: snappy: Optimise."

This causes too many rebuilds for the master branch.

This reverts commit f96ed06805.
master
Marius Bakke 2018-08-29 16:58:54 +02:00
parent 9587544b44
commit 9e17757ff5
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 8 additions and 46 deletions

View File

@ -1140,7 +1140,6 @@ dist_patch_DATA = \
%D%/packages/patches/slim-sigusr1.patch \
%D%/packages/patches/slim-reset.patch \
%D%/packages/patches/slim-login.patch \
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
%D%/packages/patches/soundtouch-CVE-2018-14044-14045.patch \
%D%/packages/patches/soundtouch-CVE-2018-1000223.patch \

View File

@ -1154,15 +1154,14 @@ algorithm within the Numpy framework.")
(package
(name "snappy")
(version "1.1.7")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/google/snappy/archive/"
version ".tar.gz"))
(file-name (string-append "snappy-" version ".tar.gz"))
(sha256
(base32 "1m7rcdqzkys5lspj8jcsaah8w33zh28s771bw0ga2lgzfgl05yix"))
(patches (search-patches "snappy-add-O2-flag-in-CmakeLists.txt.patch"))))
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/google/snappy/archive/"
version ".tar.gz"))
(file-name (string-append "snappy-" version ".tar.gz"))
(sha256
(base32
"1m7rcdqzkys5lspj8jcsaah8w33zh28s771bw0ga2lgzfgl05yix"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))

View File

@ -1,36 +0,0 @@
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 26 Aug 2018 17:24:42 +0200
Subject: [PATCH] snappy: Add O2 flag in CmakeLists.txt.
Use -O2 optimisation when building with CMake, as is already done when
using the Makefile. This patch was copied verbatim from the Snappy
mailing list[0].
[0]: <snappy-compression@googlegroups.com>
From 903c72fb29b2db07b4abc38a5feb83d88f739d80 Mon Sep 17 00:00:00 2001
From: huangwenjun <huangwenjun-hf@loongson.cn>
Date: Fri, 10 Aug 2018 17:17:35 +0800
Subject: [PATCH] Add O2 optimize flag in CmakeLists.txt.
---
CMakeLists.txt | 3 +++
1 file changed, 3 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62ecd09..29e0cdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,9 @@ set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2")
+SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2")
+
# BUILD_SHARED_LIBS is a standard CMake variable, but we declare it here to make
# it prominent in the GUI.
option(BUILD_SHARED_LIBS "Build shared libraries(DLLs)." OFF)
--
2.1.0