gnu: python-pillow: Update to 4.3.0.
* gnu/packages/python.scm (python-pillow): Update to 4.3.0. [propagated-inputs]: Add python-olefile. * gnu/packages/patches/python-pillow-freetype-2.7-test-failure.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
This commit is contained in:
parent
3a1f26ff75
commit
9e3a8ed0eb
|
@ -1025,7 +1025,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python-pandas-skip-failing-tests.patch \
|
%D%/packages/patches/python-pandas-skip-failing-tests.patch \
|
||||||
%D%/packages/patches/python-paste-remove-website-test.patch \
|
%D%/packages/patches/python-paste-remove-website-test.patch \
|
||||||
%D%/packages/patches/python-paste-remove-timing-test.patch \
|
%D%/packages/patches/python-paste-remove-timing-test.patch \
|
||||||
%D%/packages/patches/python-pillow-freetype-2.7-test-failure.patch \
|
|
||||||
%D%/packages/patches/python-pygit2-disable-network-tests.patch \
|
%D%/packages/patches/python-pygit2-disable-network-tests.patch \
|
||||||
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
|
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
|
||||||
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
||||||
|
|
|
@ -1,75 +0,0 @@
|
||||||
Fix some test failures when building with freetype-2.7.
|
|
||||||
|
|
||||||
https://github.com/python-pillow/Pillow/issues/2116
|
|
||||||
https://github.com/python-pillow/Pillow/pull/2286
|
|
||||||
|
|
||||||
Patch copied from upstream source repository:
|
|
||||||
|
|
||||||
https://github.com/python-pillow/Pillow/commit/acf68c835c93ba144f83198306aa7e6082a43f43
|
|
||||||
|
|
||||||
From acf68c835c93ba144f83198306aa7e6082a43f43 Mon Sep 17 00:00:00 2001
|
|
||||||
From: hugovk <hugovk@users.noreply.github.com>
|
|
||||||
Date: Mon, 12 Dec 2016 15:16:43 +0200
|
|
||||||
Subject: [PATCH] Increase epsilon for FreeType 2.7
|
|
||||||
|
|
||||||
---
|
|
||||||
Tests/test_imagefont.py | 15 ++++++++++-----
|
|
||||||
1 file changed, 10 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Tests/test_imagefont.py b/Tests/test_imagefont.py
|
|
||||||
index de89ac92..5207dce3 100644
|
|
||||||
--- a/Tests/test_imagefont.py
|
|
||||||
+++ b/Tests/test_imagefont.py
|
|
||||||
@@ -125,7 +125,9 @@ try:
|
|
||||||
|
|
||||||
target = 'Tests/images/rectangle_surrounding_text.png'
|
|
||||||
target_img = Image.open(target)
|
|
||||||
- self.assert_image_similar(im, target_img, .5)
|
|
||||||
+
|
|
||||||
+ # Epsilon ~.5 fails with FreeType 2.7
|
|
||||||
+ self.assert_image_similar(im, target_img, 2.5)
|
|
||||||
|
|
||||||
def test_render_multiline(self):
|
|
||||||
im = Image.new(mode='RGB', size=(300, 100))
|
|
||||||
@@ -144,7 +146,7 @@ try:
|
|
||||||
# some versions of freetype have different horizontal spacing.
|
|
||||||
# setting a tight epsilon, I'm showing the original test failure
|
|
||||||
# at epsilon = ~38.
|
|
||||||
- self.assert_image_similar(im, target_img, .5)
|
|
||||||
+ self.assert_image_similar(im, target_img, 6.2)
|
|
||||||
|
|
||||||
def test_render_multiline_text(self):
|
|
||||||
ttf = ImageFont.truetype(FONT_PATH, FONT_SIZE)
|
|
||||||
@@ -158,7 +160,8 @@ try:
|
|
||||||
target = 'Tests/images/multiline_text.png'
|
|
||||||
target_img = Image.open(target)
|
|
||||||
|
|
||||||
- self.assert_image_similar(im, target_img, .5)
|
|
||||||
+ # Epsilon ~.5 fails with FreeType 2.7
|
|
||||||
+ self.assert_image_similar(im, target_img, 6.2)
|
|
||||||
|
|
||||||
# Test that text() can pass on additional arguments
|
|
||||||
# to multiline_text()
|
|
||||||
@@ -178,7 +181,8 @@ try:
|
|
||||||
target = 'Tests/images/multiline_text'+ext+'.png'
|
|
||||||
target_img = Image.open(target)
|
|
||||||
|
|
||||||
- self.assert_image_similar(im, target_img, .5)
|
|
||||||
+ # Epsilon ~.5 fails with FreeType 2.7
|
|
||||||
+ self.assert_image_similar(im, target_img, 6.2)
|
|
||||||
|
|
||||||
def test_unknown_align(self):
|
|
||||||
im = Image.new(mode='RGB', size=(300, 100))
|
|
||||||
@@ -227,7 +231,8 @@ try:
|
|
||||||
target = 'Tests/images/multiline_text_spacing.png'
|
|
||||||
target_img = Image.open(target)
|
|
||||||
|
|
||||||
- self.assert_image_similar(im, target_img, .5)
|
|
||||||
+ # Epsilon ~.5 fails with FreeType 2.7
|
|
||||||
+ self.assert_image_similar(im, target_img, 6.2)
|
|
||||||
|
|
||||||
def test_rotated_transposed_font(self):
|
|
||||||
img_grey = Image.new("L", (100, 100))
|
|
||||||
--
|
|
||||||
2.12.0
|
|
||||||
|
|
|
@ -3686,15 +3686,14 @@ the OleFileIO module from PIL, the Python Image Library.")
|
||||||
(define-public python-pillow
|
(define-public python-pillow
|
||||||
(package
|
(package
|
||||||
(name "python-pillow")
|
(name "python-pillow")
|
||||||
(version "3.3.3")
|
(version "4.3.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri "Pillow" version))
|
(uri (pypi-uri "Pillow" version))
|
||||||
(patches (search-patches "python-pillow-freetype-2.7-test-failure.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0xkv0p1d73gz0a1qaasf0ai4262g8f334j07vd60bjrxs2wr3nmj"))))
|
"09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("python-nose" ,python-nose)))
|
`(("python-nose" ,python-nose)))
|
||||||
|
@ -3706,6 +3705,8 @@ the OleFileIO module from PIL, the Python Image Library.")
|
||||||
("openjpeg" ,openjpeg)
|
("openjpeg" ,openjpeg)
|
||||||
("libtiff" ,libtiff)
|
("libtiff" ,libtiff)
|
||||||
("libwebp" ,libwebp)))
|
("libwebp" ,libwebp)))
|
||||||
|
(propagated-inputs
|
||||||
|
`(("python-olefile" ,python-olefile)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases (modify-phases %standard-phases
|
`(#:phases (modify-phases %standard-phases
|
||||||
(add-after
|
(add-after
|
||||||
|
|
Loading…
Reference in New Issue