gnu: Removed unused patch 'readline-7.0-mingw.patch'.

This patch was introduced in commit ae12d58627,
but it was never used.

See <https://bugs.gnu.org/26581> for more information.

* gnu/packages/patches/readline-7.0-mingw.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Leo Famulari 2019-02-04 23:40:45 +01:00
parent 308d72bfe4
commit bfa3e64d7f
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
2 changed files with 0 additions and 29 deletions

View File

@ -1209,7 +1209,6 @@ dist_patch_DATA = \
%D%/packages/patches/rct-add-missing-headers.patch \
%D%/packages/patches/readline-link-ncurses.patch \
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
%D%/packages/patches/readline-7.0-mingw.patch \
%D%/packages/patches/reposurgeon-add-missing-docbook-files.patch \
%D%/packages/patches/reptyr-fix-gcc-7.patch \
%D%/packages/patches/ripperx-missing-file.patch \

View File

@ -1,28 +0,0 @@
Configure checks for chown; add missing shields in code.
Upstream status: not yet presented upstream.
--- readline-7.0/histfile.c.orig 2016-12-06 20:04:10.058901731 +0100
+++ readline-7.0/histfile.c 2016-12-06 20:05:09.220083801 +0100
@@ -610,8 +610,10 @@
user is running this, it's a no-op. If the shell is running after sudo
with a shared history file, we don't want to leave the history file
owned by root. */
+#if HAVE_CHOWN
if (rv == 0 && exists)
r = chown (filename, finfo.st_uid, finfo.st_gid);
+#endif
xfree (filename);
FREE (tempname);
@@ -757,8 +759,10 @@
user is running this, it's a no-op. If the shell is running after sudo
with a shared history file, we don't want to leave the history file
owned by root. */
+#if HAVE_CHOWN
if (rv == 0 && exists)
mode = chown (histname, finfo.st_uid, finfo.st_gid);
+#endif
FREE (histname);
FREE (tempname);